Mikrotik Unequal Dual WAN links Load Balancing


Presently this artical I will tell you the best way to design 2WAN Unequal Download and transfer speed.i have 2WAN Unequal Links WAN1 is 10mbps and WAN2 is 10mbps download and transfer data transmission in same.now I will configur Load Balcing and connection repetition arrange use pcc strategy in unequal Wan's Link.now Post end I will transfer Complet Video To Unequal WAN Loadbalcing Configuration.

Mikrotik Devices and IP Address Information

I am using MikroTik RouterOS v6.42.10.i have 2 ISP connections and a 1 LAN network. IP information that I am using for this network configuration are given below.

  • WAN1 IP 192.168.1.10/24 and Gateway IP 192.168.1.0
  • WAN2 IP 192.168.2.10/24 and Gateway IP 192.168.2.0 
  • LAN : 192.168.10.1/24 and LAN Gateway IP 192.168.10.0
  • DNS : 8.8.8.8 and 8.8.4.4
MikroTik 2 WAN Load Balancing with Failover Configuration over Unequal WAN Links

Now.you can run below command from MikroTik terminal...

/interface ethernet
set [ find default-name=ether1 ] name=ether1-WAN1
set [ find default-name=ether2 ] name=ether2-WAN2
set [ find default-name=ether3 ] name=ether3
set [ find default-name=ether4 ] name=ether4
set [ find default-name=ether5 ] name=ether5-LAN
/system note
set note="Mikrotik Configuration By |www.mikrotiksystems.com|"
/ip address
add address=192.168.1.10/24 interface=ether1-WAN1
add address=192.168.2.10/24 interface=ether2-WAN2
add address=192.168.10.1/24 interface=ether5-LAN
/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
/ip firewall mangle
add chain=input in-interface=ether1-WAN1 action=mark-connection new-connection-mark=WAN1_con
add chain=input in-interface=ether2-WAN2 action=mark-connection new-connection-mark=WAN2_con
add action=mark-routing chain=output connection-mark=WAN1_con new-routing-mark=to_WAN1
add action=mark-routing chain=output connection-mark=WAN2_con new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 in-interface=ether5-LAN
add chain=prerouting dst-address=192.168.2.0/24 in-interface=ether5-LAN
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=ether5-LAN new-connection-mark=WAN1_con per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting dst-address-type=!local hotspot=auth in-interface=ether5-LAN new-connection-mark=WAN2_con per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_con in-interface=ether5-LAN new-routing-mark=to_WAN1
add action=mark-routing chain=prerouting connection-mark=WAN2_con in-interface=ether5-LAN new-routing-mark=to_WAN2
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1
add action=masquerade chain=srcnat out-interface=ether2-WAN2
/ip route
add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
add check-gateway=ping distance=1 gateway=192.168.1.1
add check-gateway=ping distance=2 gateway=192.168.2.1

http// issues you cane face.and some images loading error.and Problems with your some secure sites,Using |both addresse and port's| or | source address and portss | For PCC Classifier..

Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.