Mikrotik 4 WAN Load Balancing Static IP's (PCC Method)


In case you're not content with the src-address approach (OR your necessities is to accomplish most exchange speed exploitation every single WAN connection simultaneously).Then play with the PCC Classifier.Try every location and ports in light of the fact that the classifier (as utilized in this guide as well).While this can disarrange things the preeminent and in principle offer you the chief genuine assignment of data measure. www.mikrotiksystems.com

Step1: Add interface Ethernet Name
  • /interface ethernet
  • set [ find default-name=ether5 ] name=LAN
  • set [ find default-name=ether1 ] name=WAN1
  • set [ find default-name=ether2 ] name=WAN2
  • set [ find default-name=ether3 ] name=WAN3
  • set [ find default-name=ether4 ] name=WAN4
Step2: Add ip Address's
  • /ip address
  • add address=192.168.0.1/24 interface=LAN network=192.168.0.0
  • add address=192.168.1.2/24 interface=WAN1 network=192.168.1.0
  • add address=192.168.2.2/24 interface=WAN2 network=192.168.2.0
  • add address=192.168.3.2/24 interface=WAN3 network=192.168.3.0
  • add address=192.168.4.2/24 interface=WAN4 network=192.168.4.0
Step3: Add DNS

/ip dns

set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

/system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes

Step4:Add Firewall Mangle Rule
  • /ip firewall mangle
  • add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=WAN1_conn
  • add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=WAN2_conn
  • add action=mark-connection chain=input in-interface=WAN3 new-connection-mark=WAN3_conn
  • add action=mark-connection chain=input in-interface=WAN4 new-connection-mark=WAN4_conn
  • add action=mark-routing chain=output connection-mark=WAN1_conn new-routing-mark=to_WAN1
  • add action=mark-routing chain=output connection-mark=WAN2_conn new-routing-mark=to_WAN2
  • add action=mark-routing chain=output connection-mark=WAN3_conn new-routing-mark=to_WAN3
  • add action=mark-routing chain=output connection-mark=WAN4_conn new-routing-mark=to_WAN4
  • add action=accept chain=prerouting dst-address=192.168.1.0/24 in-interface=LAN
  • add action=accept chain=prerouting dst-address=192.168.2.0/24 in-interface=LAN
  • add action=accept chain=prerouting dst-address=192.168.3.0/24 in-interface=LAN
  • add action=accept chain=prerouting dst-address=192.168.4.0/24 in-interface=LAN
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=\
  •     both-addresses-and-ports:4/0
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=\
  •     both-addresses-and-ports:4/1
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN3_conn passthrough=yes per-connection-classifier=\
  •     both-addresses-and-ports:4/2
  • add action=mark-connection chain=prerouting dst-address-type=!local in-interface=LAN new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=\
  •     both-addresses-and-ports:4/3
  • add action=mark-routing chain=prerouting connection-mark=WAN1_conn in-interface=LAN new-routing-mark=to_WAN1
  • add action=mark-routing chain=prerouting connection-mark=WAN2_conn in-interface=LAN new-routing-mark=to_WAN2
  • add action=mark-routing chain=prerouting connection-mark=WAN3_conn in-interface=LAN new-routing-mark=to_WAN3
  • add action=mark-routing chain=prerouting connection-mark=WAN4_conn in-interface=LAN new-routing-mark=to_WAN4
Step5: Add Firewall Nat Rule
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=WAN1
  • add action=masquerade chain=srcnat out-interface=WAN2
  • add action=masquerade chain=srcnat out-interface=WAN3
  • add action=masquerade chain=srcnat out-interface=WAN4
Step6: Add Route
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
  • add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
  • add check-gateway=ping distance=1 gateway=192.168.3.1 routing-mark=to_WAN3
  • add check-gateway=ping distance=1 gateway=192.168.4.1 routing-mark=to_WAN4
  • add check-gateway=ping distance=1 gateway=192.168.1.1
  • add check-gateway=ping distance=2 gateway=192.168.2.1
  • add check-gateway=ping distance=3 gateway=192.168.3.1
  • add check-gateway=ping distance=4 gateway=192.168.4.1
if You Have face eny error View This Video.


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.