Mikrotik 4 PPPoE User connections Load Balancing (NTH Method)


This post represents on anyway you'll tack load leveling of numerous wan connections exploitation Mikrotik Routerboard equipment (or RouterOS x86 variant). amid this precedent I even have utilized Mikrotik Routerboard metallic component 750hex without fat model. four ports ar associated with Four pppoe users,and fifth port was associated with User PC arrange. Remember to rename the interface names therefore in case you're a copy glue.

Step1: Add interface ethernet
  • /interface ethernet
  • set [ find default-name=ether5 ] name=Local
Step2: Add ip Address
  • /ip address
  • add address=192.168.20.1/24 interface=Local network=192.168.20.0
Step3: Add ip DNS
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
Step4: Add interface pppoe-client
Dont Forget All User Name and Password in (user1-1234),(user2-1234),(user3-1234),(user4-1234)..
  • /interface pppoe-client
  • add disabled=no interface=Local max-mru=1480 max-mtu=1480 name=pppoe-out1 \
  •     password=1234 use-peer-dns=yes user=user1
  • add disabled=no interface=Local max-mru=1480 max-mtu=1480 name=pppoe-out2 \
  •     password=1234 user=user2
  • add disabled=no interface=Local max-mru=1480 max-mtu=1480 name=pppoe-out3 \
  •     password=1234 user=user3
  • add disabled=no interface=Local max-mru=1480 max-mtu=1480 name=pppoe-out4 \
  •     password=1234 user=user4
Step5: Add Firewall Nat Rule
  • /ip firewall nat
  • add action=masquerade chain=srcnat connection-mark=conn1 out-interface=\
  •     pppoe-out1
  • add action=masquerade chain=srcnat connection-mark=conn2 out-interface=\
  •     pppoe-out2
  • add action=masquerade chain=srcnat connection-mark=conn3 out-interface=\
  •     pppoe-out3
  • add action=masquerade chain=srcnat connection-mark=conn4 out-interface=\
  •     pppoe-out4
Step6: Add Firewall Mangle Rule
  • /ip firewall mangle
  • add action=mark-connection chain=prerouting connection-state=new in-interface=\
  •     Local new-connection-mark=conn1 nth=4,1 passthrough=yes
  • add action=mark-routing chain=prerouting connection-mark=conn1 in-interface=\
  •     Local new-routing-mark=conn1 passthrough=no
  • add action=mark-connection chain=prerouting connection-state=new in-interface=\
  •     Local new-connection-mark=conn2 nth=4,2 passthrough=yes
  • add action=mark-routing chain=prerouting connection-mark=conn2 in-interface=\
  •     Local new-routing-mark=conn2 passthrough=no
  • add action=mark-connection chain=prerouting connection-state=new in-interface=\
  •     Local new-connection-mark=conn3 nth=4,3 passthrough=yes
  • add action=mark-routing chain=prerouting connection-mark=conn3 in-interface=\
  •     Local new-routing-mark=conn3 passthrough=no
  • add action=mark-connection chain=prerouting connection-state=new in-interface=\
  •     Local new-connection-mark=conn4 nth=4,3 passthrough=yes
  • add action=mark-routing chain=prerouting connection-mark=conn4 in-interface=\
  •     Local new-routing-mark=conn4 passthrough=no
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step7: Add Route
  • /ip route
  • add distance=1 gateway=pppoe-out1 routing-mark=conn1 scope=255
  • add distance=1 gateway=pppoe-out2 routing-mark=conn2 scope=255
  • add distance=1 gateway=pppoe-out3 routing-mark=conn3 scope=255
  • add distance=1 gateway=pppoe-out4 routing-mark=conn4 scope=255
  • add distance=1 gateway=pppoe-out1
  • add distance=3 gateway=pppoe-out3
  • add distance=2 gateway=pppoe-out2
  • add distance=4 gateway=pppoe-out4
  • /system identity
  • set name=Mikrotiksystems.com
if you have face error to view this video:Download Complete Script {Download}


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.