Mikrotik 2 WAN Load Balancing With Static IP (ECMP Method)


This post represents on however you may put along burden compromise of different wan connections abuse Mikrotik Routerboard equipment (or RouterOS x86 form). all through this example I even have utilized Mikrotik Routerboard Rb 750 hex light model. 3 port's was associated with line hardware. what's more, one port was associated with User network.Don't neglect to rename the interface names subsequently in the event that you are a copy glue.

Add interface ether name
  • /interface ethernet
  •  set ether5 name=LAN
  •  set ether1 name=WAN1
  •  Set ether2 name=WAN2
Step1: Add ip Address
  • /ip address
  • add address=192.168.50.1/24 interface=LAN network=192.168.60.0
  • add address=192.168.1.12/24 interface=WAN1 network=192.168.1.0
  • add address=192.168.2.12/24 interface=WAN2 network=192.168.2.0
Step2: Add DNS Address
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step3: Add Firewall Nat Rule
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=WAN1
  • add action=masquerade chain=srcnat out-interface=WAN2
Step4: Add Firewall Mangle Rule
  • /ip firewall mangle
  • add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=\
  •     WAN1_Conn passthrough=yes
  • add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
  •     WAN2_Conn passthrough=yes
  • add action=mark-routing chain=output connection-mark=WAN1_Conn \
  •     new-routing-mark=WAN1_Conn passthrough=no
  • add action=mark-routing chain=output connection-mark=WAN2_Conn \
  •     new-routing-mark=WAN2_Conn passthrough=no
Step5: Add Route ip
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=WAN1_Conn
  • add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=WAN2_Conn
  • add check-gateway=ping distance=1 gateway=192.168.1.12,192.168.2.12
if you have face any error to view this video Download Complete Script {Download}



Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.