Mikrotik 2 WAN Load Balancing With 2 LAN's (NTH Method)


You can gather load compromise of numerous wan connections abuse Mikrotik Routerboard equipment (or RouterOS x86 adaptation). amid this precedent I really have utilized Mikrotik Routerboard metal 750hex without fat model. two ports ar associated with Four DSL electronic equipment,and 2 port was associated with User LAN. Remember to rename the interface names thusly in case you're a reproduction glue.

Step1: Add ip Address
  • /ip address
  • add address=192.168.60.1/24 interface=LAN1 network=192.168.60.0
  • add address=192.168.60.1/24 interface=LAN2 network=192.168.60.0
  • add address=192.168.1.12/24 interface=WAN1 network=192.168.1.0
  • add address=192.168.2.12/24 interface=WAN2 network=192.168.2.0
Step2: Add Firewall Nat Rule
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=WAN1
  • add action=masquerade chain=srcnat out-interface=WAN2
Step3: Add Firewall Mangle Rule
  • /ip firewall mangle
  • add action=mark-connection chain=input in-interface=WAN1 new-connection-mark=\
  •     WAN1_conn
  • add action=mark-connection chain=input in-interface=WAN2 new-connection-mark=\
  •     WAN2_conn
  • add action=mark-routing chain=output connection-mark=WAN1_conn \
  •     new-routing-mark=to_WAN1
  • add action=mark-routing chain=output connection-mark=WAN2_conn \
  •     new-routing-mark=to_WAN2
  • add chain=prerouting dst-address=192.168.1.0/24 in-interface=LAN
  • add chain=prerouting dst-address=192.168.2.0/24 in-interface=LAN
  • add action=mark-connection chain=prerouting dst-address-type=!local \
  •     in-interface=LAN new-connection-mark=WAN1_conn per-connection-classifier=\
  •     both-addresses-and-ports:2/0
  • add action=mark-connection chain=prerouting dst-address-type=!local \
  •     in-interface=LAN new-connection-mark=WAN2_conn per-connection-classifier=\
  •     both-addresses-and-ports:2/1
  • add action=mark-routing chain=prerouting connection-mark=WAN1_conn \
  •     in-interface=LAN new-routing-mark=to_WAN1
  • add action=mark-routing chain=prerouting connection-mark=WAN2_conn \
  •     in-interface=LAN new-routing-mark=to_WAN2
Step4: Add Route ip
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=to_WAN1
  • add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=to_WAN2
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
if you have face any error to view this videoDownload Complete Script {Download}


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.