Mikrotik 2 WAN Load Balancing Static IP (NTH Method)


This post delineates on yet you will probably put along burden leveling of numerous wan connections exploitation Mikrotik Routerboard equipment (or RouterOS x86 adaptation). all through this case I even have utilized Mikrotik Routerboard rubidium 750 hex skim model. an attempt of port's was associated with connecter gear. also, one port was associated with User local space network.Don't neglect to rename the interface names thus on the off chance that you are a multiplication glue.

Note: if you have more then 2 WANs you just add:
  • ip --> Address
  • ip --> firewall -->Mangle
  • ip --> firewall --> NAT
  • ip --> route.
Step1: Add interface ether name
  • /interface ethernet
  • set [ find default-name=ether5 ] name=LAN
  • set [ find default-name=ether1 ] name=WAN1
  • set [ find default-name=ether2 ] name=WAN2
  • set [ find default-name=ether3 ] name=ether3
  • set [ find default-name=ether4 ] name=ether4
Step2: Add ip Address
  • /ip address
  • add address=192.168.60.1/24 interface=LAN network=192.168.60.0
  • add address=192.168.1.12/24 interface=WAN1 network=192.168.1.0
  • add address=192.168.2.12/24 interface=WAN2 network=192.168.2.0
Step3: Add DNS
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step4: Add Firewall Mangle Rule
  • /ip firewall mangle
  • add chain=prerouting in-interface=LAN connection-state=new nth=2,1 action=mark-connection new-connection-mark=conn1 passthrough=yes comment="" disabled=no
  • add chain=prerouting in-interface=LAN connection-mark=conn1 action=mark-routing new-routing-mark=conn1 passthrough=no comment="" disabled=no
  • add chain=prerouting in-interface=LAN connection-state=new nth=2,2 action=mark-connection new-connection-mark=conn2 passthrough=yes comment="" disabled=no 
  • add chain=prerouting in-interface=LAN connection-mark=conn2 action=mark-routing new-routing-mark=conn2 passthrough=no comment="" disabled=no
Step5: Add Firewall Nat Rule
  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=WAN1
  • add action=masquerade chain=srcnat out-interface=WAN2
Step6: Add Route ip
  • /ip route
  • add check-gateway=ping distance=1 gateway=192.168.1.1 routing-mark=conn1
  • add check-gateway=ping distance=1 gateway=192.168.2.1 routing-mark=conn2
  • add check-gateway=ping distance=1 gateway=192.168.1.1
  • add check-gateway=ping distance=2 gateway=192.168.2.1
if you have face any error to view this videoDownload Complete Script {Download}


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.