Mikrotik 1WAN and 1 PPPoE Connection Load Balancing (NTH Method)


This post delineates on anyway you'll set up burden evening out of numerous wan connections abuse Mikrotik Routerboard equipment (or RouterOS x86 variant). amid this precedent I really have utilized Mikrotik Routerboard metal 750hex light model. one port square measure associated with Four pppoe user,1 port was associated with telephone line electronic equipment.and one port was associated with User neighborhood neglect to rename the interface ether.

Step1: Add interface Ethernet add
  • /interface ethernet
  •  set ether0 name=Local
  •  set ether1 name=WAN
Step2: Add ip Address
  • /ip address
  • add address=192.168.60.1/24 interface=LAN network=192.168.60.0
  • add address=192.168.1.12/24 interface=WAN network=192.168.1.0
Step3: Add DNS Address
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step4: Add Pppoe Client Username and password
  • /interface pppoe-client
  • add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
  •     dial-on-demand=no disabled=no interface=LAN max-mru=1480 \
  •     max-mtu=1480 mrru=disabled name=pppoe-out2 password=1234 profile=default \
  •     service-name="" use-peer-dns=yes user=user1
Step5: Add Firewall Mangle Rule
  • /ip firewall mangle
  • add chain=prerouting in-interface=LAN connection-state=new nth=2,1 action=mark-connection new-connection-mark=conn1 passthrough=yes comment="" disabled=no
  • add chain=prerouting in-interface=LAN connection-mark=conn1 action=mark-routing new-routing-mark=conn1 passthrough=no comment="" disabled=no
  • add chain=prerouting in-interface=LAN connection-state=new nth=2,2 action=mark-connection new-connection-mark=conn2 passthrough=yes comment="" disabled=no
  • add chain=prerouting in-interface=LAN connection-mark=conn2 action=mark-routing new-routing-mark=conn2 passthrough=no comment="" disabled=no
Step6: Add Firewall Nat Rule
  • /ip firewall nat
  • add chain=srcnat connection-mark=conn1 action=masquerade out-interface=WAN comment="" disabled=no
  • add chain=srcnat connection-mark=conn2 action=masquerade out-interface=pppoe-out2 comment="" disabled=no
Step7: Add Route ip's
  • /ip route
  • add dst-address=0.0.0.0/0 gateway=192.168.1.1 scope=255 target-scope=10 routing-mark=conn1 comment="" disabled=no
  • add dst-address=0.0.0.0/0 gateway=pppoe-out2 scope=255 target-scope=10 routing-mark=conn2 comment="" disabled=no
  • add dst-address=0.0.0.0/0 gateway=192.168.1.1 comment="" disabled=no
  • add dst-address=0.0.0.0/0 gateway=pppoe-out2 comment="" disabled=no
if you have face any error to view this videoDownload Complete Script {Download}


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.