Mikrotik 1 WAN and 1 PPPoE Connection Load Balancing and FailOver (PPC Method)


This post represents on yet you'll put on burden compromise of numerous wan connections misuse Mikrotik Routerboard equipment (or RouterOS x86 adaptation). all through this occurrence I even have utilized Mikrotik Routerboard nuclear number 750 hex skim model. 3 port's was associated with line instrumentality. what's more, one port was associated with User network.Don't neglect to rename the interface names thusly in case you're a proliferation glue.

Step1: Add interface Ethernet Name
  • /interface ethernet 
  •  set ether5 name=Local
  •  set ether1 name=isp
Step2: Add ip Address
  • /ip address
  •  add address=192.168.2.1/24 interface=Local
  •  add address=192.168.10.12/24 interface=isp
Step3: Add DNS Address
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step4: Add Pppoe Client Username and password
  • /interface pppoe-client
  • add ac-name="" add-default-route=no allow=pap,chap,mschap1,mschap2 comment="" \
  •     dial-on-demand=no disabled=no interface=Local max-mru=1480 \
  •     max-mtu=1480 mrru=disabled name=pppoe-out1 password=1234 profile=default \
  •     service-name="" use-peer-dns=yes user=user1
Step5: Add Firewall Mangle Rule
  • /ip firewall mangle
  •  add chain=input in-interface=pppoe-out1 action=mark-connection new-connection-mark=isp1_conn
  •  add chain=input in-interface=isp action=mark-connection new-connection-mark=isp2_conn
  •  add chain=output connection-mark=isp1_conn action=mark-routing new-routing-mark=to_isp1
  •  add chain=output connection-mark=isp2_conn action=mark-routing new-routing-mark=to_isp
  •  add chain=prerouting action=accept in-interface=pppoe-out1
  •  add chain=prerouting action=accept in-interface=isp
  •  add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=isp1_conn passthrough=yes
  •  add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=isp2_conn passthrough=yes
  •  add chain=prerouting connection-mark=isp1_conn in-interface=Local action=mark-routing new-routing-mark=to_isp1
  •  add chain=prerouting connection-mark=isp2_conn in-interface=Local action=mark-routing new-routing-mark=to_isp2
Step6: Add Firewall Nat Rule
  • /ip firewall nat
  •  add chain=srcnat out-interface=pppoe-out1 action=masquerade
  •  add chain=srcnat out-interface=isp action=masquerade
Step7: Add Route ip
  • /ip route
  •  add dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=to_isp1 check-gateway=ping
  •  add dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-mark=to_isp2 check-gateway=ping
  •  add dst-address=0.0.0.0/0 gateway=pppoe-out1 distance=1 check-gateway=ping
  •  add dst-address=0.0.0.0/0 gateway=192.168.10.1 distance=2 check-gateway=ping
if you have face any error to view this videoDownload Complete Script {Download}



Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.