How To Configuration PPPOE Server With DHCP Server


Now Team Today i will Show you how to configur Mikrotik Router Board 750 With PPPOE Server and 4 Lan Out internet Configuration.

First it will inquire as to whether you need to keep on introducing the Dialer.Then it will limit all opened Window to Let client center the installation.Then it will demonstrate to you the Logo in front(dialer.jpg which is adaptable as indicated by your need).in Background it will open the Network and sharing focus and make new section for pppoe dialer.After making dialer, it will close the Logo and will demonstrate you.

Let's Start.

Step1: Add  interface ether Name
  • /interface ethernet
  • set [ find default-name=ether1 ] name=WAN
Step2: Add ip address WAN and LAN
  • /ip address
  • add address=192.168.10.5/24 interface=WAN network=192.168.10.0
  • add address=192.168.55.5/24 interface="LAN OUT" network=192.168.55.0
Step3: Add interface bridge
  • /interface bridge
  • add name="LAN OUT"
  • /interface bridge port
  • add bridge="LAN OUT" interface=ether5
  • add bridge="LAN OUT" interface=ether4
  • add bridge="LAN OUT" interface=ether3
  • add bridge="LAN OUT" interface=ether2
Step4: Add a New Pool
  • /ip pool
  • add name=pool1_pppoe ranges=10.5.50.2-10.5.50.254
  • add name=dhcp_pool1 ranges=\
  •     192.168.60.1-192.168.60.4,192.168.60.6-192.168.60.254
Step5: Add Dhcp Server
  • /ip dhcp-server
  • add address-pool=dhcp_pool1 disabled=no interface="LAN OUT" name=dhcp1
  • /ip dhcp-server lease
  • add address=192.168.60.2 client-id=1:0:23:ae:9c:7b:ea mac-address=\
  •     00:23:AE:9C:7B:EA server=dhcp1
  • /ip dhcp-server network
  • add address=192.168.60.0/24 gateway=192.168.60.5
Step6: Add Queue Simple
  • /queue simple
  • add max-limit=1M/1M name=awais target=10.5.50.11/32
Step7: Add Interface Pppoe Server
  • /interface pppoe-server server
  • add disabled=no interface="LAN OUT" one-session-per-host=yes service-name=\
  •     pppoe_service
  • /ppp secret
  • add local-address=10.5.50.1 name=admin password=1234 remote-address=10.5.50.11 \
  •     service=pppoe
  • /system note set note="Mikrotik Configuration By |www.mikrotiksystems.com|" show-at-login=yes
Step8: Add  DNS Address
  • /ip dns
  • set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4
Step9: Add Firewall Nat

  • /ip firewall nat
  • add action=masquerade chain=srcnat out-interface=WAN
  • add action=masquerade chain=srcnat disabled=yes src-address=192.168.60.0/24
Step10: Add Route Ip
  • /ip route
  • add distance=1 gateway=192.168.10.1
if you have face error to view this video: Download Complete Configuration {Script}


Author  Bilal Ahmad

• Hands on Experience with Cisco & Huawei Layer 2 & Layer 3 devices and Mikrotik Routers. • Maintained and managed several long distances RF point to point and point to multipoint links.